We want your online experience with Pepnet 2 to be the best. The browser you are currently using is not supported. Click on one of the supported browser button for a free download.
You may need to work with your IT to get a supported browser installed to replace your current browser that is becoming obsolute.
A validation e-mail has been sent to your e-mail address. In order to gain full access to the site, you will need to follow the instructions in that message.

User account

Primary tabs

LIVE CHAT
 
 
 
FROM THE FORUM
Student preferences for specific...
by scarmich | 7/10/14 @ 11:58 AM
Financial Aid/Scholarships
by mcpark | 7/9/14 @ 09:36 AM
Hearing aids
by mounces | 7/3/14 @ 09:01 AM
The pepnet 2 website is compatible with Internet Explorer 8+, Chrome 14+, Safari 4+ and Firefox 3+. Compatibility with earlier versions of browsers is limited.